Вопрос: Совместимость изображений виртуальных машин между VMware Server и VMware Player


Я пытаюсь свести к минимуму количество различных версий продуктов, используемых на моем ПК как на работе, так и дома. Пока у меня есть смесь:

  • VMware Server 1.0.7
  • VMware Server 2.0.2
  • VMware Player 2.5.3
  • VMware Player 3.0.0

и я хотел бы обновить каждое семейство продуктов до последней версии.

поскольку Руководство по мобильности виртуальной машины отмечен как устаревший, может ли кто-нибудь указать мне какую-то свежую информацию о совместимости виртуальной машины между VMware Player и VMware Server, чтобы все еще иметь возможность перемещать виртуальные машины назад и вперед между упомянутыми продуктами?

Обновить Я ищу обновленный документ с версиями аппаратных средств виртуальных машин и продуктами VMware, которые могут использовать эту конкретную версию аппаратного обеспечения, поэтому я могу знать - с учетом продуктов, которые используют определенную виртуальную машину, - что является максимальным которая может обновить виртуальную машину.


7
2017-12-12 14:29


Источник




Ответы:


Важным для продуктов vmWare является аппаратная версия виртуальной машины. Вы можете получить эту версию, если вы посмотрите параметры совместимости в настройках многих продуктов vmWare. Также см. Ссылку на список поддерживаемых версий продуктов и оборудования.

Версии оборудования vmWare


2
2017-12-03 16:50





Вы всегда можете использовать Конвертер VMware vCenter для обновления совместимости ваших виртуальных машин и использования их с более новыми продуктами.


1
2017-12-12 18:20



так как я не могу обновить все линейки продуктов, как я могу узнать, что обновление все же позволяет мне использовать виртуальную машину с предыдущей версией? - alexandrul
Конвертер будет делать то, что он говорит о жесте, - он преобразует из одной версии аппаратного обеспечения VM (или физической машины, если на то пошло), в другую, если это требуется целевой. - Helvick
Конвертер VMware также не будет разбивать или изменять исходную виртуальную машину, которую вы использовали, - она ​​просто копирует ее в новом формате. - Joe Heck


Я бы предложил две разные вещи:

(1) Обновить все виртуальные машины до самой последней версии Player / Workstation

(2) Аннотация вашего интерфейса к виртуальным машинам, поэтому вам нужен только один сервер (ESXi)?

(3) Не переходите к настоящей версии сервера VMware, так как это ужасно.


1
2018-04-13 18:53



(1) Я бы с удовольствием, но есть и другие пользователи со старыми версиями, и я хочу обновить свой Player / Server до последней версии, которая не требует версии HW, не поддерживаемой более старыми версиями. - alexandrul
(2) Это не мое решение :( (3) Спасибо за отзыв - alexandrul


Я не вижу причин, по которым вы не можете сделать виртуализацию при виртуализации и сохранить свои существующие продукты.

Например. Сервер VMware поверх рабочей станции / ESXi и т. Д.


1
2018-04-14 07:25





почему бы просто не сделать копию ваших изображений, а затем попробовать конвертер VMware, и если он, похоже, запускается впоследствии. Будьте счастливы, если нет - найдите дополнительную информацию о том, как ее исправить или принять? Я бы ... Я знаю, это может показаться пустой тратой времени, но если это сработает, зачем смотреть дальше? У вас все еще есть данные в безопасном резервном копировании, поэтому его легко сделать откат - или?


1
2018-04-29 01:55





хорошо, я знаю, что это не тот точный ответ, который вы ищете, но по моему опыту он работает следующим образом: новые версии могут использовать старые виртуальные машины, а наоборот - работает большую часть времени, но не все.

В большинстве случаев, если вы хотите использовать виртуальную машину, созданную в новой версии на старой, вам нужно только отредактировать файл .vmx и изменить настройку конфигурации аппаратного уровня. Если он создан в старой версии, он работает как в новом, так и в старом, если вы не выполняете обновление аппаратного обеспечения VM.

Однако в одной из версий (я точно не знаю, к сожалению) формат .vmdk также изменился, и эти новые диски вы не можете прочитать в более старых версиях. Я считаю, что лучше всего создать небольшую виртуальную виртуальную машину и просто попробовать ее с версиями и посмотреть, как это происходит.


1
2018-05-21 15:36





Мы перемещаем изображения между сервером VMWare (v 2.x), работающим на Centos, Player в Windows и Fusion (эквивалент Mac рабочей станции). Он работал нормально, при этом иногда необходимо вручную редактировать файл определения виртуальной машины (например, CDROM, являющийся E: или / dev / sdb)


1
2017-07-07 18:09





Протестировано до сих пор:

VMware Server 1.0.10-203137

  • создает и запускает виртуальные машины:
    • virtualHW.version = "4"

Сервер VMware 2.0.2-203138

  • создает и запускает виртуальные машины:
    • virtualHW.version = "7"
    • virtualHW.version = "6"
    • virtualHW.version = "4"
  • обновляет виртуальные машины:
    • из virtualHW.version = "6" в virtualHW.version = "7"
    • из virtualHW.version = "4" в virtualHW.version = "7"

VMware Player 2.5.4-246459

  • запускает виртуальные машины с:
    • virtualHW.version = "4"

VMware Player 3.1.3-324285

  • создает виртуальные машины с:
    • virtualHW.version = "7"
  • запускает виртуальные машины с:
    • virtualHW.version = "7"
    • virtualHW.version = "6"
    • virtualHW.version = "4"

VMware Player 4.0.4-744019

  • создает виртуальные машины с:
    • virtualHW.version = "8"
  • запускает виртуальные машины с:
    • virtualHW.version = "8"
    • ...

VMware Player 5.0.0-812388

  • создает виртуальные машины с:
    • virtualHW.version = "9"
  • запускает виртуальные машины с:
    • virtualHW.version = "9"
    • virtualHW.version = "8"
    • ...

0
2017-11-10 09:21