Вопрос: Экран дисплея GNU + от шпатлевки


Кто-нибудь знает, как получить +-*/ на цифровой клавиатуре работать на экране GNU от шпатлевки?

Числа работают нормально, но не операторы. / похоже, связывается с переименованием текущей оболочки или может начать новую оболочку. Моя ОС хоста - ubuntu 9.04 (OS, на котором я запускаю экран).


6
2018-05-29 07:22


Источник




Ответы:


Если в вашем .screenrc установлено следующее: клавиши numpad будут работать

termcapinfo xterm ks@:ke@

Я не знаю, изменит ли это какие-либо другие важные настройки, которые вы, возможно, используете, так что стоило бы сдавать экзамены.

Возможно, что есть лучшая строка настроек, но до сих пор я не смог ее найти.

Обновить:
Я искал вокруг, просматривая TERMCAP, TERMINFO, TERMINFO / TERMCAP а также экран  руководства, но похоже, что никому не повезло с тем, чтобы одновременно работать как в цифровой клавиатуре, так и в клавишах со стрелками в приложениях ncurses (они все еще работают в приложениях, отличных от ncurses).

Ближайший я видел от эти  потоки, Кто-то говорил с одним из сопровождающих программы относительно почти идентичной проблемы, однако с 10 марта проблема не была решена.


8
2018-05-29 10:09



Приятно, что сработало :). Должен видеть, что что-то еще ломается, но, надеюсь, нет. - Buzzzz
Хм, купите так, что клавиши со стрелками перестали работать в midknight commander и centerim .. - Buzzzz
Исправлено это для меня тоже, никаких проблем в каких-либо приложениях пока. - red


Вы можете проверить конфигурацию, перейдите к

Terminal

--> Keyboard

     --> Function keys and keypad

Выберите то, что работает для вас. Как правило, Linux / Xterm R6


3
2018-05-29 07:32



Ну, он отлично работает, если я не использую экран. Похоже, что по какой-то причине экран переплетает эти ключи. - Buzzzz
то же здесь @Buzzzz, но он исправляет это для меня. vim без экрана, клавиши F1-12 работают нормально. под экраном, я получаю: ^ [[14something. Теперь, если я установил настройку шпатбливания на «vt100 +» (настройка linux ничего не сделала), тогда я получу клавиши F1-12, работающие на vim под экраном. - gcb


Другая конфигурация, которая работала для меня:

Перейти к: Конфигурация шпатлевки -> Terminal-> Особенности

Проверить Disable application keypad mode установите флажок.

http://vim.wikia.com/wiki/PuTTY_numeric_keypad_mappings


2
2018-03-09 10:51





Как ответ Энди добавляет termcapinfo xterm ks@:ke@ на ~ / .screenrc исправлена ​​проблема в оболочке, и клавиши со стрелками работают.

Однако клавиши управления стрелками перестали работать в VIM, что для меня заменило проблему еще более серьезной проблемой.

Поэтому я добавил вместо этого ~ / .screenrc

termcapinfo xterm* ks@:ke@:kl=\E[D:kd=\E[B:kr=\E[C:ku=\E[A

Все идет нормально.


0
2017-10-09 13:58