Вопрос: glibc 2.7 на CentOS 5.5?


Я пытаюсь запустить программу, требующую glibc 2.7, но я запускаю ее на CentOS 5.5. Есть какой-либо способ сделать это? Я не могу перейти на CentOS 6.


6
2018-03-22 01:07


Источник


Вам нужно будет обновить или посмотреть, может ли программа быть скомпилирована против старого glibc в CentOS 5 - ewwhite


Ответы:


Хм. glibc 2.5 - это зависимость от почти всего в CentOS5. Если вы измените его на glibc 2.7, ваша коробка взорвется.

Вот несколько обсуждений на форумах CentOS:

https://www.centos.org/modules/newbb/viewtopic.php?topic_id=28345&forum=41

https://www.centos.org/modules/newbb/viewtopic.php?viewmode=flat&topic_id=27133&forum=38


9
2018-03-22 01:16





Я столкнулся с этим вопросом пару раз, совсем недавно, когда вернулся с помощью Snort. Пытаясь перейти на 2.7, вы обязательно взорвете свою коробку. Я сделал свою тестовую систему не загружаемой, когда я попробовал это ранее. Лучше всего обновить, если это вообще возможно. В противном случае многие приложения могут быть перекомпилированы против glib 2.6. Если вам нужно иметь дело с отсутствием установки из источника в вашей производственной инфраструктуре, посмотрите, как создавать RPM. Многие продукты либо содержат спецификационный файл, либо есть один общедоступный.


0
2018-03-22 01:54



У вас была проблема с клавиатурой при написании первой части? - CommunistPancake
Новый мобильный телефон. Автокоррекция требует некоторой корректировки. - Tim Brigham