Вопрос: Должен ли я использовать haproxy's "linux2628" или "linux26" сделать цель?


С последними версиями HAProxy просто набрав make не работает, возвращая следующее сообщение:

Из-за слишком большого количества сообщений о субоптимизированных установках,   указание цели больше не поддерживается. Укажите, пожалуйста,   целевой ОС в переменной TARGET, в следующей форме:

сделать TARGET = xxx

Выберите целевой список среди следующих поддерживаемых списков:

linux2628, linux26, linux24, linux24e, linux22, solaris freebsd,   openbsd, cygwin, custom, generic

Используйте «generic», если вам не нужна оптимизация, «custom», если вы хотите   точно настроить любой вариант или выбрать цель, которая соответствует   вашей ОС, чтобы получить максимальную производительность.   Пожалуйста, проверьте Makefile в случае сомнений.

В чем разница между linux2628 а также linux26 ? Могу ли я использовать linux2628 даже если у меня новая версия ядра?


6
2018-01-08 20:23


Источник




Ответы:


Да, вы можете использовать linux2628,

Из gmane.comp.web.haproxy список рассылки (взятый из 1.5-dev11's changelog)

- added a build target "linux2628" which is like linux26 but automatically
includes splicing and tproxy.

8
2018-01-08 20:23