Вопрос: connect () не удалось (111: соединение отказано) при подключении к восходящему потоку


Я испытываю 502 Gateway ошибки при доступе к файлу PHP в каталоге (http://example.com/dev/index.php). Журналы просто говорят об этом:

2011/09/30 23:47:54 [error] 31160#0: *35 connect() failed (111: Connection refused) while connecting to upstream, client: xx.xx.xx.xx, server: domain.com, request: "GET /dev/ HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "domain.com"

Я никогда раньше этого не испытывал. Каково решение для этого типа 502 Gateway ошибка?

Это nginx.conf:

user www-data;
worker_processes 4;
pid /var/run/nginx.pid;

events {
    worker_connections 768;
    # multi_accept on;
}

http {

    ##
    # Basic Settings
    ##

    sendfile on;
    tcp_nopush on;
    tcp_nodelay on;
    keepalive_timeout 65;
    types_hash_max_size 2048;
    # server_tokens off;

    # server_names_hash_bucket_size 64;
    # server_name_in_redirect off;

    include /etc/nginx/mime.types;
    default_type application/octet-stream;

    ##
    # Logging Settings
    ##

    access_log /var/log/nginx/access.log;
    error_log /var/log/nginx/error.log;

    ##
    # Gzip Settings
    ##

    gzip on;
    gzip_disable "msie6";

    # gzip_vary on;
    # gzip_proxied any;
    # gzip_comp_level 6;
    # gzip_buffers 16 8k;
    # gzip_http_version 1.1;
    # gzip_types text/plain text/css application/json application/x-javascript text/xml application/xml application/xml+rss text/javascript;

    ##
    # Virtual Host Configs
    ##

    include /etc/nginx/conf.d/*.conf;
    include /etc/nginx/sites-enabled/*;
}


#mail {
#   # See sample authentication script at:
#   # http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript
# 
#   # auth_http localhost/auth.php;
#   # pop3_capabilities "TOP" "USER";
#   # imap_capabilities "IMAP4rev1" "UIDPLUS";
# 
#   server {
#       listen     localhost:110;
#       protocol   pop3;
#       proxy      on;
#   }
# 
#   server {
#       listen     localhost:143;
#       protocol   imap;
#       proxy      on;
#   }
#}

66
2017-09-30 21:59


Источник


«Отказано в подключении» означает, что бэкэнд не прослушивает порт 9000 или его очередь заполняется. Эта проблема связана с бэкэндом. Можете ли вы использовать telnet localhost 9000? Вы также должны проверить свои бэкэнд и журналы php. - Andrew
Обновлено мое сообщение. Я не мог telnet подключиться к localhost 9000. - MacMac
Та же ошибка, с которой я столкнулся, введите ссылку здесь могу помочь тебе - Tripathi29


Ответы:


Похоже, что вы еще не начали и не сконфигурировали бэкэнд для Nginx. Начало php-fpm и добавьте следующее к nginx.conf, в http контекст:

server {
    listen 127.0.0.1;
    server_name localhost;

    error_log /var/log/nginx/localhost.error_log info;

    root /var/www/localhost/htdocs;

    location ~ \.php$ {
        fastcgi_pass 127.0.0.1:9000;
        include /etc/nginx/conf.d/*.conf;
        include /etc/nginx/sites-enabled/*;

        fastcgi_intercept_errors        on;
        error_page 404 /error/404.php;
    }
}

35
2017-10-01 11:03



Спасибо, человек, это сработало, у меня не было php-fpm установлен. Приветствия. - MacMac
Ты чистый гений. Я не могу поверить 1.0000000 миллионов руководств, которые я читал об этом, NOBODY упоминает, что вы должны поставить «listen 127.0.0.1» для включения бэкэнд. Ты спас меня от кошмара !!!
вы должны рассмотреть возможность использования сокета unix. Просмотрите его с помощью netstat -l и см. /var/run/php5-fpm.sock (config для этого обычно находится в /etc/php5/fpm/pool.d/www.conf. fastcgi_pass unix:<socket> - JohannesM
у вас будет listen = /var/run/php5-fpm.sock внутри /etc/php5/fpm/pool.d/www.conf, но вы захотите listen = 9000 а также ;listen = /var/run/php5-fpm.sock, если бы вы были похожи на меня. (иначе вы могли бы услышать мудрый намек JohannesM, который, я думаю, оставил бы вам что-то вроде fastcgi_pass unix:/var/run/php5-fpm.sock;где-то в вашем nginx.conf) - n611x007
Имея ту же проблему с php 7.2. Что вы подразумеваете под добавлением файла в контексте httpd? Будет ли это дополнительный файл conf в / etc / nginx / sites-available / folder или что? - PeterKA


Этот ответ предназначен только для тех, кто получает такую ​​ошибку:

connect () не удалось (111: соединение отказано) при подключении к восходящему потоку, клиенту ....   FastCGI: // [:: 1]: 9000

Перепишите свою конфигурацию nginx для использования ip, а не dns. Например, 127.0.0.1 вместо localhost, или удалить псевдоним ipv6 из / etc / hosts.


35
2018-02-18 15:58



Ты указал мне в правильном направлении! Я использую только listen 80 (и есть много примеров с этим), но я не думал, что это подразумевает как IPv4 (127.0.0.1) и IPv6 ([::1]). - glarrain
Мне пришлось перейти от listen 80 default_server в listen 0.0.0.0:80, - givanse
Можете ли вы указать Зачем это должно помочь? - kaiser
Большинство бесплатных дистрибутивов Linux поддерживают ipv6 в сети, но не все пакеты, настроенные для использования ipv6. На мой взгляд, когда nginx инициирует соединение с восходящим потоком, системный резольвер сначала возвращает ipv6-адрес. Php-fpm (centos 7.x) не имеет таких настроек из окна. И большинство руководств объясняют все в версии ipv4, забывая о фьючерсах ipv6, которые следует отключить или использовать. - Quake1TF
Whooah, поэтому [:: 1] - адрес localhost IPv6! :) Благодаря! - lechup


Также были ошибки. Проблема заключалась в том, что мой абстрактный бэкэнд ссылался на два сервера. php-fpm был только список сокетов ...

# Upstream to abstract backend connection(s) for php
upstream php {
        server unix:/var/run/php5-fpm.sock;
        #server 127.0.0.1:9000;
} 

server {
    [...]

    location ~ \.php$ {
            # NOTE: You should have "cgi.fix_pathinfo = 0;" in php.ini

            # With php5-fpm:
            fastcgi_pass php;
            fastcgi_index index.php;
            fastcgi_intercept_errors on;
            include fastcgi_params;
    }
}

2
2018-05-22 13:45





В моем случае ошибка была плохим местом для файла error_log для службы php5.6-fpm, и, таким образом, Служба php-fpm не начала а также nginx не смог подключиться к нему, Вы можете найти его в /etc/php/5.6/fpm/php.ini (вы можете заменить 5.6 на версию, которую вы используете).


0
2017-07-30 15:03





Имела ту же проблему с прокси-серверами на сервере Node, который прослушивал порт 5000. Запросы будут 200 OK но когда-нибудь 502 Bad Gateway случайно. NGINX показала ошибку:

connect() failed (111: Connection refused) while connecting to upstream, client: ..., server: ...

Мое решение:

  1. Установить HTTP-сервер узла Слушать строго для ipv4 путем включения localhost как хост: server.listen(5000, 'localhost'); 
  2. Удалены любые директивы ipv6 listen (listen [::]:80; или listen [::]:443 ssl default_server;).
  3. Изменен блок-адрес proxy_pass для использования IP-адресов: proxy_pass http://127.0.0.1:5000 (не proxy_pass http://localhost:5000).

Надеюсь, это поможет кому-то.


0
2017-07-05 10:05





У меня была такая же проблема и добавление выражения для прослушивания

listen 127.0.0.1;

работал на меня.

Интересно, что у меня есть другие серверные блоки, которые бегают довольно счастливо без этого!


-3
2017-11-26 22:48



Об этом уже ответили и приняли уже три года назад. - Sven♦