Вопрос: Не удалось подключиться к FTP - Тайм-аут подключения после MLSD


Итак, вот моя проблема, я абсолютно не могу подключиться к FTP-серверу, в обстоятельствах, которые я никогда раньше не видел. Вот ситуация:

  • Я получаю «Время ожидания соединения» сразу после команды MLSD.
  • Обычно я использую Filezilla под Ubuntu, но чтобы убедиться, что проблема не связана с этим конкретным клиентом, я попробовал несколько других: gftp на ubuntu и winscp и freeftp на Windows 7. Все тот же результат.
  • Также попробуйте активировать активные или пассивные режимы. Тот же результат.
  • В этот момент я был бы склонен думать, что с моей нынешней сетью что-то не так (кроме того, по словам коллеги, FTP-сервер в порядке). Но я проверял http://ftptest.net/ и я могу получить список каталогов (который я не могу выполнить через FTP-клиент).

Поэтому, в конце концов, последнее, что я не пробовал, - это пойти в другую сеть, решение, которая, похоже, сработает, но в долгосрочной перспективе это будет не очень практично. И, таким образом, я думаю, что что-то не так с моим маршрутизатором ... но что это может быть?

Примечание. Сначала я попытался зарегистрироваться и опубликовать этот вопрос на доске filezilla ... но я не могу создать учетную запись с учетной записью gmail или hotmail. WTF?


9
2018-01-20 05:31


Источник


Для информации у нас также была проблема с MLSD, но это не проблема с файерволом, а слишком много файлов в каталоге (более 40 000). - Marc MAURICE
У меня тоже была эта пробема. Как ни странно, проблема была решена после добавления конфигурации сервера в Site Manager и установки типа UNIX в качестве сервера. - Emiswelt
В FileZilla версии 3.21 мне нужно было переключить «Использовать простой FTP (небезопасный)» в настройках подключения, чтобы он работал. Теперь я буду играть с настройками на сервере, чтобы сделать его не таким «неуверенным». - Miro J.


Ответы:


Согласно администраторам FileZilla, ваш маршрутизатор, вероятно, является проблемой (хотя вы, вероятно, ничего не можете с этим поделать), и они не собираются исправлять это, чтобы вернуться к списку, если MLSD истечет. Видеть: http://forum.filezilla-project.org/viewtopic.php?f=2&t=11405&start=15

Решение: попробуйте Core FTP или аналогичный. Вряд ли вы сможете убедить упрямых людей FileZilla добавить (тупо простую) обходную опцию - «вернуться к списку, если MLSD истечет».

Или, поскольку это открытый исходный код, посмотрите, сможете ли вы или кто-то другой внести изменения и скомпилировать их самостоятельно. Я предполагаю, что если вы попытаетесь представить изменения, которые будут добавлены в официальную сборку, они отклонят ее, но, возможно, мы были бы приятно удивлены.


6
2018-06-02 17:57



Хорошо знать! Gnome Commander подключен просто отлично. - styu
Вау, какой профессиональный и полезный ответ на этом форуме FileZilla: «Прекратите использовать ваш глупый брандмауэр, тогда он не является частью протокола FTP». - basic6
+1 для вежливого критического тона! - Miro J.


После долгого поиска решение было простым:

Идти к Site Management, выберите сайт с проблемой. Выберите вкладку Transfer Settings и выберите Active вместо Default,


6
2018-03-28 08:55





Я нашел проблему в шифрование когда я изменил его на «Использовать только простой FTP (небезопасный)», тогда он отлично работает!

FileZilla очень мне знакома, и мне нужно бороться за ошибки при каждом ее обновлении.


3
2018-04-02 02:03



Afaik этот вопрос не был специфичным для ftp-клиента и не был специфичным для Windows. - peterh
Учитывая, что отключить TLS - плохой совет. Конечно, это решает проблему, вызванную использованием TLS, но это приводит к небезопасному соединению ... - Yvan


Я исправил проблему, используя туннель ssh через один из моих личных серверов. Я абсолютно зациклен на том, почему это сработает. Я в настоящее время в Японии и мой сервер в Канаде, поэтому, возможно, проблема с адресом IPv6 (хотя сервер говорит, что это не должно) ...?


1
2018-01-21 01:51





Просто хочу, чтобы люди знали, как я получил эту работу.

С тайм-аутом MLSD проблема может также возникать в маршрутизаторе.

У меня появился новый маршрутизатор Asus, и я неправильно перенаправил порты для пассивного режима. У меня есть qnap NAS, и я подключаюсь к порту 21 на ftp и порту xxxxx: xxxxx в пассивном режиме. В моем маршрутизаторе asus я правильно настроил порт вперед (виртуальный сервер), и он снова работает. Мой FTP правильно перенаправлен на порт 21 на мой IP-адрес NAS, просто стандартный. Проблема заключалась в пассивных портах, которые хотел использовать NAS.

Я сделал это в разделе переадресации порта (Virtual Server вызывается в маршрутизаторах ASUS):

Название услуги: Whateveryoulike

Диапазон портов: пассивные порты, которые будет использовать ваше устройство (стандарт 55536: 56559 для Qnap)

Локальный IP: локальный IP-адрес устройства (что-то вроде 192.168.0.xxx)

Локальный порт: ОСТАВЬТЕ ЭТО БЛАНК

Протокол: оба

Добавить

Подать заявление

БУМ! Мы поднялись вверх.

Проблема может быть чем-то другим, но это фиксировало мой тайм-аут, и теперь все это работает.


1
2017-08-09 16:33





Если вы подключаетесь к серверу unix и запускаете iptables (брандмауэр), проверьте конфигурацию iptables в / И т.д. / sysconfig / iptable-конфигурации, для этой строки:

IPTABLES_MODULES = ""

если он пуст, отредактируйте его следующим образом:

IPTABLES_MODULES =»ipt_MASQUERADE iptable_nat nf_nat nf_conntrack_ftp"

и перезагрузите или перезапустите iptables: перезапустите службу iptables (или перезапустите). Теперь попробуйте подключиться (с пассивным режимом), и он должен работать без проблем.

Это устранило нашу проблему, в офисе, на рабочих столах с Windows 7 / 8.1, за NAT и соединившись с WinSCP 5.5.3 с рабочим сервером, работающим с CentOS 6.6 x86_64, Plesk 12 и ProFTPd.

Вам не нужно делать какие-либо сумасшедшие настройки в вашем ftp-клиенте.

Ура, Майкл.

PS: для этого вам потребуется SSH-доступ и права root.


0
2018-04-30 13:28





Как и другие, я потратил много времени на эту проблему.

Теперь я исправил проблему.

Я использовал FireFTP (бесплатное дополнение к Firefox), и он работал легко, в первый раз.

Одна вещь, которую я заметил, - это то, что FireFTP по умолчанию не соответствует порту 21.

С другой стороны, FileZilla не разрешала заполнять порт Port (он по умолчанию будет пустым). Возможно, это было частью проблемы.

Я пробовал все, о чем упоминалось ранее (изменение на Active, разрешение Filezilla прошло через брандмауэр и т. Д.), И никто не работал для меня (у меня Windows 10).


0
2017-09-26 17:07





У меня была такая же проблема, и я пытался подключиться через Quick connect на порту 2222. Затем я использовал Site Manager с приведенными ниже настройками и больше не ошибкой:

  • порт 2222
  • протокол SFTP
  • Тип входа Обычный
  • пользователя и пароль

Затем сразу же подключился менеджер сайта.


-1
2018-03-21 09:56





Это преатит просто!

Вы должны добавить брандмауэр для Fillzilla (или любого используемого вами клиента).

(Если это не сработает, это может быть что-то вроде брандмауэра или порта на вашем маршрутизаторе.)

PS: Изменение режима вашего подключения к активному может быть трюком, но это не «лучшее решение». ;-)


-3
2017-11-18 05:57